Home Forums Lorina Add to Cart missing

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #12717
    EKP
    Participant

    I have a woocommerce website, but it’s not really for buying but more as a catalog that people can request more items.

    In each product page, you can select a color variation (or multiple color variations). Once you select it, it should have a button that says “Add to Cart” along with qty. option (if you want more than 1, you can choose that too). I’ve already reconfigured this in the Woocommerce settings to actually say “Request Sample”.

    This Add to Cart button, however, never shows up and is missing in all the pages. I’ve also read mutliple forums that suggest deactivating all the plug-ins as some may interfere with this, to see which one interferes. I’ve tried that and it still does not show up and I’m at a loss to how to figure this out. Can someone please help me??

    Website is https://e.yoma.com/collection/    you can click on any of the products on this page to see.

    Using Lorina theme.

    #12724
    Andy
    Keymaster

    The ‘YITH WooCommerce Catalog Mode’ plugin is hiding the add to cart button with this CSS:

    form.cart button.single_add_to_cart_button, form.cart .quantity, .woocommerce-variation-price{display: none !important}

    You can add the following CSS to ‘Customize’ > ‘Additional CSS’ and it should override the YITH code:

    form.cart button.single_add_to_cart_button {
        display: block !important;
    }
    #12730
    EKP
    Participant

    Hi, thank you for the custom CSS. I added it and the “Add to Cart” button now shows up.

    But it does not work – meaning, I can select a variation and click add to cart, but it will not actually add it to the cart. The cart remains empty.

    Two other issues related to this:

    – In the Yith Catalog settings, I had replaced “Add to Cart” to read “Request Sample”. Is this a separate issue that requires a separate thread?
    – Original settings, in addition to the “Add to Cart” button, there should be a ” – # + ” button so you can select quantity of how many you want (ie., “- 3 + ” if you want three or “- 1 +” as default). This also does not show up anymore. It shows up in the template and as a original woocommerce setting.

    How to fix this?

    I primarily am using Yith Catalogue mainly to hide all the pricing which we don’t want it to be visible on the website.

    #12731
    Andy
    Keymaster

    For the quantity selectors, you will notice that the CSS from the YITH plugin is also setting this to not display. To make this display you just need to add form.cart .quantity to the previous code, like so:

    form.cart .quantity,
    form.cart button.single_add_to_cart_button {
        display: block !important;
    }

    Regarding the other issues, it may be that the YITH Catalog plugin is disabling the cart functionality, to ensure it really is catalog mode only. You would need to ask the plugin support for help with this, as it is outside the scope of the theme.

    Also with with regard to changing the button text, if that plugin has options to change this, then this is also outside the scope of the theme, and I would recommend you consult the plugin’s documentation or ask their support for help.

    #12752
    EKP
    Participant

    Thank you for your help!! The CSS worked for the quantity buttons coming up again. Will reach out to YITH for the other issues.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.