Thanks, I can see that you are running PHP version 5.2.17
That part of the theme requires at least version 5.6 of PHP.
I would very much recommend that you update (or ask your web host to update) your PHP version to 5.6 or later (preferably version 7) as you will most likely encounter more problems with other themes/plugins and possibly even the core WordPress installation.
See the WordPress requirements which states that the absolute minimum required is 5.2.4 and that even this version has reached end of life and may expose your site to security vulnerabilities. Link here: https://wordpress.org/about/requirements/