Home Forums Trusted Pro Parsec error while installing

This topic contains 4 replies, has 2 voices, and was last updated by  Karol May 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2817

    Karol May
    Participant

    Hey, installed trusted pro.1.1.1. zip into wp (newest version 4.9).

    Parse error: syntax error, unexpected T_FUNCTION in /wp-content/themes/trusted- pro/functions/trusted-theme- mods.php on line 196

    Getting this information… need to remove theme manually using ftp as i cant do nothing in wp. Tried in 4.8 previously, same message.

    I unchecked any plugins or custom css. What is this problem about?

    #2818

    Andy
    Keymaster

    Sorry to see you are experiencing a problem with the theme.

    We are not getting this error on any of our test sites or our demo.

    So that I can investigate this further, could you let me know the version of PHP that your server is running?

    If you have WooCommerce installed, go to ‘WooCommerce’ > ‘Status’ and under the ‘Server environment’ heading it will say PHP version:

    If you are not using WooCommerce, could you install the Debug Info plugin, then look in ‘Dashboard’ > ‘Debug Info’ where it will show which version of PHP you have.

    #2819

    Karol May
    Participant

    Not using woocommerce.

    Free version of trusted theme was working good.

    Here is info from debug info plugin:

    WordPress Version: 4.9
    Current WordPress Theme: Trusted version 1.1.10
    Theme Author: uXL Themes – http://uxlthemes.com
    Theme URI: http://uxlthemes.com/theme/trusted
    Active Plugins: debug-info/debug-info.php |
    PHP Version: 5.2.17
    MySQL Version: 5.7.18-14-log

     

    #2823

    Andy
    Keymaster

    Thanks, I can see that you are running PHP version 5.2.17

    That part of the theme requires at least version 5.6 of PHP.

    I would very much recommend that you update (or ask your web host to update) your PHP version to 5.6 or later (preferably version 7) as you will most likely encounter more problems with other themes/plugins and possibly even the core WordPress installation.

    See the WordPress requirements which states that the absolute minimum required is 5.2.4 and that even this version has reached end of life and may expose your site to security vulnerabilities. Link here: https://wordpress.org/about/requirements/

    #2846

    Karol May
    Participant

    I can confirm, that with version 5.6.30 of php  the problem is gone.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.