Home Forums Azuma No header images when switching languages

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9337
    elvis
    Participant

    Hi, I have installed your theme, and it is great!

    I am using the plugin Polylang to use two languages on my website. When switching to the 2nd language, the header images are not displayed. When switching back to the standard language, everything works fine.

    Can you tell me how to get the header images working in both languages?

    Thanks.

    #9338
    elvis
    Participant

    I already found the solution:

    in the media settings, each images is assigned with a language. If you upload an image, it is automatically assigned with the standard language.

    If you switch to 2nd language, polylang doesnt display these images because they are assigned to the other language.

    the solution is to upload a duplicate of each image and in the media library select the 2nd language.

    Then, in the Customize options of Azuma, upload also these header images.

     

    Hope it helps somebody.

    #9340
    Andy
    Keymaster

    Hello, good to hear you found a solution, thank you for the information.

    I think Polylang works this way so that there is the option to have different header images when switching languages.

    We will look into finding a way to have the header image displayed across all languages by default unless it is selected that they should be different.

    #9341
    Andy
    Keymaster

    Okay, we have done some testing and the site-wide header image as selected in the customizer is displayed correctly across all languages, so you shouldn’t need to upload a duplicate image for each language.

    The header image can also be changed per post/page in the post/page editor with the ‘Featured Image’.

    Let’s say you have ‘Language 1’ and you create a page ‘Page 1’ for that language. If you upload/select a featured image, this will be displayed as the header image for ‘Page 1’ in ‘Language 1’.

    Then you create a ‘Language 2’ version of ‘Page 1’, if you leave the ‘Featured Image’ empty, the site-wide header image will be displayed for ‘Page 1’ in ‘Language 2’. So, to have the same ‘Featured Image’ you just need to select the same image, no need to reupload a duplicate image.

    Hope this helps and that I have explained it adequately.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.