Home Forums Exoplanet Pro Read More… problem

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #7526
    Red Wortham
    Participant

    When I insert  a ‘more’ tag into a post where I want the  summary to end and show a ‘Read More…’ link the ‘Read More…’ link does not appear on the blog roll when the post is published. The ‘Read More…’ link only appears if I allow the post to choose the location itself. I really don’t like how long the summaries are by default. Any tips on fixing this issue?

    #7529
    Yazmin
    Keymaster

    Hello, the summaries are by default the first 110 words of the post’s content.

    It could be that you are placing the ‘more’ tag after this point, if you add the ‘more’ tag before 110 words it will display a ‘Continue Reading’ link on the blogroll.

    Our other themes have an option to change the default excerpt length, and I don’t know why this setting is not present in Exoplanet Pro.
    I will see if we can add this option and push it through as a theme update.

    #7531
    Yazmin
    Keymaster

    The theme has now been updated to include an option to change the length of the excerpt.

    There is also a new option to display the full post content on the blogroll should you wish to make use of this instead of displaying the excerpt/summary.

    Please update Exoplanet Pro to version 1.6.5 and you will see these new settings at ‘Appearance’ > ‘Customize’ > ‘Blog Settings’

    #7540
    Red Wortham
    Participant

    Thank you ever so much for that added feature Yazmin. It works well to automatically create shorter blog post summaries for my site. It’s much appreciated!

    Might I suggest that we be able to customize the title of our site in the header? I used a plugin that allows me to add to headers globally to set a <Title> for the page but it failed to work. (I really didn’t expect it would but I tried….) I think my site being called “Home – Name of my site” looks rather amateurish–like a hobby site or some such a thing. Not that anything’s wrong with hobby sites but the site I’m working on is more professional. It’d be nice if, in the customizer, under ‘Site Identity’ where we name our site, the name we enter is the name we get when someone saves it as a favorite or anywhere else that is seen. Appending the individual page name to the site title, if done, should come after the site’s name should it not? Anyway, it’s a thought….I’m sure I’ll figure out how to change that eventually even if comes to changing some code in the theme somewhere….it’s not a high priority at the moment.

    #7544
    Andy
    Keymaster

    Thank you for getting back to us and letting us know that the options to change the summary length works well.

    Regarding the header titles, by default the homepage header will use the ‘Site Title’ and ‘Tagline’ from the ‘Site Identity’ options in the customizer.

    For example in our demo the homepage header title is “Exoplanet Pro Demo – WordPress demo from UXL Themes”. The actual name of that page in the editor is “Sample Page” (we didn’t rename it from the initial setup).

    The other pages/posts will use the title of the page/post followed by the ‘Site Title’, so for example a page named ‘About Us’ would have the header title of “About Us – Exoplanet Pro Demo”.

    If you have a page named “Home” that is not the static homepage, then yes the header will be “Home – Name of my site”. If this is the case you can simply rename the page something other than “Home” to make it look more professional.

    The theme uses the standard WordPress way of outputting the headers so any plugin that also follows the WordPress coding standards to make changes to the headers will work correctly with the theme.

    What is the name of the plugin that you tried?

    #7545
    Andy
    Keymaster

    Just to add some more clarification, on your site I can see you are using the Yoast SEO plugin. This plugin does things slightly differently in regards to the static homepage.

    When Yoast SEO is active, it will render the header title of the static homepage using the same format of the other pages e.g. “Page Name – Name of site”.
    It is not the theme that is doing this, it is the Yoast SEO plugin. It is overriding the standard WordPress way of generating the header title for the static homepage.

    To change this, in your dashboard go to the page editor for the page that is set as your homepage and edit the Yoast SEO setting for ‘Snippet Preview’ > ‘SEO Title’.

    If you look at the Yoast SEO ‘Search Appearance’ page (Dashboard > SEO > Search Appearance) it explains this like so:

    Homepage & Front page

    You can determine the title and description for the front page by editing the front page itself.

    #7549
    Red Wortham
    Participant

    Thank you Andy and thanx again Yazmin. Your insights have been so helpful in getting my website up, running, and looking great.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.