Home Forums Azuma Pro Social Icon in top bar

Tagged: 

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #9106
    Kevin Wilson
    Participant

    How do you get social icons in the top bar and not be 1st icon on the left side of page and 2nd icon on the right side of the page then the 3rd goes under the 1st icon on the left again??

    How do I get them all lined up either left, right or middle, and how can I adjust icon to a smaller size

    #9108
    Andy
    Keymaster

    It sounds like you have the icons each in a separate widget.

    You can put all the icons in the same widget so they will display all together.

    The theme is designed so that each separate widget is displayed like you describe. This is because you may want social icons in one widget and different content in another widget, and this way they won’t all be bunched together.

    #9109
    Kevin Wilson
    Participant

    Hi Andy, yes it is the only was to add extra icons?, i cant see any other way to add in the same widget

    #9110
    Andy
    Keymaster

    Is it a plugin that you are using to create the icons?
    It sounds like the plugin creates a separate widget for each icon.
    If so, please let me know which plugin.

    Or, do you have it on a live site that I can take a look at please?

    #9111
    Andy
    Keymaster

    Is it the site from your email domain?

    It looks okay to me and the social icons are all in the same widget.
    Did you work out how to put them in the same widget?

    #10160
    Robin Weiss
    Participant

    I can’t even figure out how to get any social media icons on the top bar or others. It’s not in widgets.

    • This reply was modified 2 months, 3 weeks ago by Robin Weiss.
    #10162
    Andy
    Keymaster

    Hi Robin

    They were using a plugin for this functionality. Sadly they didn’t reply to confirm or say which plugin was being used.

    #10220
    Joanna Page
    Participant

    hi Andy

    Is there a way to add the social media icons to the top menu without a widget? I’ve got the icons onto the footer – that worked and then I tried the suggestions in the Trusted forum, but that didn’t work for Azuma (funnily enough…!).

    Also is there a way to get the links to open in a new tab?

    thanks!

     

    #10221
    Andy
    Keymaster

    Hi Joanna

    The best way is to use a widget.

    First create a new menu, give the menu a name, leaving the ‘Display location’ options unchecked.

    Add your social media links to the menu using the ‘Custom Links’ option.

    In the ‘Link text’ enter this code: <i class="fab fa-facebook"></i>
    …for twitter, instagram etc replace facebook as appropriate.

    To have the link open in a new tab, select the ‘Open link in a new tab’ option.

    Save the menu.

    Now go to the Widgets area and add a ‘Navigation Menu’ widget to the ‘Top Bar’ widget area.
    Select the menu you created earlier and save the widget.

    Your social media links with icons will now be displayed in the top bar.

    See the screenshots below.

    Adding custom links to a menu

    Adding a navigation menu widget to the top bar

    #10227
    Joanna Page
    Participant

    hi Andy, thank you.

    That has mostly worked… just 2 things:

    1. on top bar, is there a way to have more locations? when i create the widget it appears on the LH of the screen but I would like it on the RH side – i can’t see that option?

    2. when creating the menu, i don’t have the option to open in a new window. Here’s a screenshot – can you advise?

    thanks

     

     

    #10233
    Andy
    Keymaster

    The widgets in the top bar are automatically 50/50 left/right on larger screens.
    If you add an empty text widget before your menu widget, this will make the menu appear to the top right.

    For the new window option, click ‘Screen Options’ in the top right of the widgets page, and make sure to select the ‘Link Target’ option under the ‘Show advanced menu properties’ heading.

    #10234
    Joanna Page
    Participant

    brilliant! thanks Andy – that’s all working a treat now.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.