Forum Replies Created

Viewing 15 posts - 1 through 15 (of 68 total)
  • Author
    Posts
  • in reply to: Instagram button #8502
    Adri Oosterwijk
    Participant

    That’s great, thanks!

    in reply to: Target Blank in Featured Service Link #8434
    Adri Oosterwijk
    Participant

    Ok…. thanks… hope it will be added shortly and thanks for the temporary solution.

    Adri Oosterwijk
    Participant

    Seems to be ok now…. thanks…

    Have anice day!

    Adri Oosterwijk
    Participant

    Hi Andy,

    Thanks again for taking the time to explain.

    It took me all day but it seems that I was able to figure it out and to solve it.

    It was a WPML related issue. As I had transferred my images to Amazon S3 and Imgix WPML had no clue where to find the Dutch Images. So every image url was wrong when viewing the site in Dutch. The background color is defined in the css and when no image is found to display the area is colored with the background color. See screenshot.

    The plugin Media Cloud is not compatible (yet) with WPML officially but I found a workaround on their support site. After adding a tiny bit of code in my functions.php everything is working as expected.

    Marked resolved!

    Adri Oosterwijk
    Participant

    Hi Andy,

    Thank you for your reply.

    This puzzles me. I found “header-view” in a couple of files:

    • /wp-includes/js/customize-views.js
    • /wp-content/plugins/wpml-translation-management/inc/js-scripts.php
    • /wp-admin/css/customize-controls.css
    • +some minified files

    The second one is from one of the WPML plugins. I think it has something to do with them. As told I’m working on the Amazon S3 an Imgix integration using the Media Cloud plugin. I know that this plugin is not yet WPML compatible. I think that is causing it.

    I have 30 different header images on my site

    In another, older, copy of the site, without the Media Cloud plugin, there are 60 images listed. Thirty duplicates. Apparently, those are listed for both languages.

    You told me that the randomize functionality is not a part of the theme. A very long time ago I had a plugin called: WP Display Header by Konstantin Obenland. This plugin added the functionality. However, when I discovered that it could also be set in the customizer I deleted the plugin.

    So, there is no plugin active or even installed and I’m totally lost where it is coming from. Any ideas left?

     

    Adri Oosterwijk
    Participant

    Resolved! Great Support! Thanks.

    in reply to: Change the background colors of the dropdown menu #6563
    Adri Oosterwijk
    Participant

    Resolved

    in reply to: Change the background colors of the dropdown menu #6482
    Adri Oosterwijk
    Participant

    Sorry, my bad!

    I stared about an hour or so on it and never noticed it…….

    Thanks for correcting my flaw.

    Adri Oosterwijk
    Participant

    That’s absolutely great! Thanks. It works for the category and tags pages in English and Dutch.

    I added || is_shop() to the conditional myself to get it working in the Dutch shop and search result pages as well. Thank you so much, you made my day!

     

    Adri Oosterwijk
    Participant

    Herewith two screenshots:

    one with the header image in place (original theme) and one with the !is_woocommerce() conditional invoked. Please be so kind to help me out here. Apparently, the page structure has changed also to an extent that the page is messed up.

    Adri Oosterwijk
    Participant

    Mmm…. I see that I’ve given you wrong info. I’m totally confused. Forget the part about the missing (or changed) div. Really don’t know what is happening.

    Adri Oosterwijk
    Participant

    Spending the last couple of hours to find a solution (following your advice) I noticed in the WooCommerce docs a partial solution.

    I wrapped the call for the header in an if statement:

    ‘ if (!is_woocommerce()){
    if ($trusted_custom_header) {
    trusted_custom_header_title($trusted_this_id);
    } else {
    trusted_header_title();
    }
    }’

    The header is disappeared but also is the <div class=”container clearfix”> changed to <div id=”content” class=”site-content clearfix”>

    The result is that the page becomes full with (no container of 1160px and the content is shifted to the upper left corner, partially hidden by the (so to say) header bar.

    I could not find a way to fix this myself so, again, I need your help. (Sorry)

     

    in reply to: Removing header image (and page title) on product archive pages. #6415
    Adri Oosterwijk
    Participant

    Yes…. and more

    It basically boils down to all archives which are displaying products in all languages.

    • Product archives (shop page) -> archive-product.php
    • Product search results -> archive-product.php
    • Product categories -> taxonomy-product_cat.php
    • Product tags -> taxonomy-product_tag.php
    • Are there more? I need it on those too. 🙂

    Note that it has to be in all languages (existing and new to add).

    As always, thanks for your help.

    in reply to: Removing header image (and page title) on product archive pages. #6413
    Adri Oosterwijk
    Participant

    Hi Andy, thanks for your reply.

    The Categories I can manage this way because there are only 31 of them in 2 languages (that makes 62). That is a one time operation.

    The tags is a different story. At this moment (with approx. 1.000 products) I have already 2.280 distinct tags in English and 2.280 tags in Dutch and more to come when more products and/or languages are added.

    As this is very time-consuming to edit all categories and tags manually I am hoping for a better solution.

    A function for in my functions.php perhaps? That could (should) solve my multilingual issue also.

    What I meant was that a translated page exists ‘on its own’ like you said. The strange thing however is when I try to edit the translated page (which is possible) with the normal page editor, I’m not able to do so because I’m presented with a different interface as shown in the screenshots.

    To ask WPML for help is useless because the Trusted Pro theme is not on their compatibility list (yet). They simply don’t know what to do.

    Again, I do hope you are able to help me out with a code solution that covers it all.

    I do not mention to extend the theme with this option as I know that there are not many customers who want this. As I have a very big amount of products +1000 right now and thousands more to come I need to have as much screen real estate as possible.

    Please help…..

    Adri Oosterwijk
    Participant

    I noticed that the above-described method not functions when I try to do the same on a (WPML) translated page (product archive). The editor for the header area differs in the English and the Dutch page. I do hope and trust you have a solution.

    See screenshots.

    English header area

    Dutch header area

    English product page

    Dutch product page

Viewing 15 posts - 1 through 15 (of 68 total)